1 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
2 # Contributor: Mario BlÀttermann <mario.blaettermann@gmail.com>
3 # Contributor: Benjamin Vialle <archlinux@vialle.io>
4 # Contributor: Rafael Fontenelle <rafaelff@gnome.org>
7 pkgname=('man-pages-cs'
30 pkgdesc="Translation of man pages"
32 url="https://salsa.debian.org/manpages-l10n-team/manpages-l10n"
36 changelog=$pkgbase.changelog
37 options=('!emptydirs')
38 source=("$url/-/archive/$pkgver/manpages-l10n-$pkgver.tar.bz2")
39 sha256sums=('efa90d0182672e5e2366354dcd4526f79a21b3abd5796900fd5f296d9bab8b79')
42 cd manpages-l10n-$pkgver
43 ./configure --prefix=/usr --enable-distribution=archlinux --enable-compression=none
45 for _lang in cs da de el es fi fr hu id it mk nb nl pl pt_BR ro ru sr sv uk vi; do
51 cd manpages-l10n-$pkgver
53 for _lang in cs da de el es fi fr hu id it mk nb nl pl pt_BR ro ru sr sv uk vi; do
54 make check -k -C po/"${_lang}"
58 package_man-pages-cs() {
59 pkgdesc="Czech man pages"
62 cd manpages-l10n-$pkgver/po/cs
63 make DESTDIR="${pkgdir}" install
66 package_man-pages-da() {
67 pkgdesc="Danish man pages"
70 cd manpages-l10n-$pkgver/po/da
71 make DESTDIR="${pkgdir}" install
74 package_man-pages-de() {
75 pkgdesc="German man pages"
78 cd manpages-l10n-$pkgver/po/de
79 make DESTDIR="${pkgdir}" install
82 package_man-pages-el() {
83 pkgdesc="Greek man pages"
86 cd manpages-l10n-$pkgver/po/el
87 make DESTDIR="${pkgdir}" install
90 package_man-pages-es() {
91 pkgdesc="Spanish man pages"
94 cd manpages-l10n-$pkgver/po/es
95 make DESTDIR="${pkgdir}" install
98 package_man-pages-fi() {
99 pkgdesc="Finnish man pages"
102 cd manpages-l10n-$pkgver/po/fi
103 make DESTDIR="${pkgdir}" install
106 package_man-pages-fr() {
107 pkgdesc="French man pages"
110 cd manpages-l10n-$pkgver/po/fr
111 make DESTDIR="${pkgdir}" install
114 package_man-pages-hu() {
115 pkgdesc="Hungarian man pages"
118 cd manpages-l10n-$pkgver/po/hu
119 make DESTDIR="${pkgdir}" install
122 package_man-pages-id() {
123 pkgdesc="Indonesian man pages"
126 cd manpages-l10n-$pkgver/po/id
127 make DESTDIR="${pkgdir}" install
130 package_man-pages-it() {
131 pkgdesc="Italian man pages"
134 cd manpages-l10n-$pkgver/po/it
135 make DESTDIR="${pkgdir}" install
138 package_man-pages-mk() {
139 pkgdesc="Macedonian man pages"
142 cd manpages-l10n-$pkgver/po/mk
143 make DESTDIR="${pkgdir}" install
146 package_man-pages-nb() {
147 pkgdesc="Norwegian bokmÄl man pages"
150 cd manpages-l10n-$pkgver/po/nb
151 make DESTDIR="${pkgdir}" install
154 package_man-pages-nl() {
155 pkgdesc="Dutch man pages"
158 cd manpages-l10n-$pkgver/po/nl
159 make DESTDIR="${pkgdir}" install
162 package_man-pages-pl() {
163 pkgdesc="Polish man pages"
166 cd manpages-l10n-$pkgver/po/pl
167 make DESTDIR="${pkgdir}" install
170 package_man-pages-pt_br() {
171 pkgdesc="Brazilian Portuguese man pages"
174 cd manpages-l10n-$pkgver/po/pt_BR
175 make DESTDIR="${pkgdir}" install
178 package_man-pages-ro() {
179 pkgdesc="Romanian man pages"
182 cd manpages-l10n-$pkgver/po/ro
183 make DESTDIR="${pkgdir}" install
186 package_man-pages-ru() {
187 pkgdesc="Russian man pages"
190 cd manpages-l10n-$pkgver/po/ru
191 make DESTDIR="${pkgdir}" install
194 package_man-pages-sr() {
195 pkgdesc="Serbian man pages"
198 cd manpages-l10n-$pkgver/po/sr
199 make DESTDIR="${pkgdir}" install
202 package_man-pages-sv() {
203 pkgdesc="Swedish man pages"
206 cd manpages-l10n-$pkgver/po/sv
207 make DESTDIR="${pkgdir}" install
210 package_man-pages-uk() {
211 pkgdesc="Ukrainian man pages"
214 cd manpages-l10n-$pkgver/po/uk
215 make DESTDIR="${pkgdir}" install
218 package_man-pages-vi() {
219 pkgdesc="Vietnamese man pages"
222 cd manpages-l10n-$pkgver/po/vi
223 make DESTDIR="${pkgdir}" install