archrelease: copy trunk to community-any
[ArchLinux/community.git] / mate-sensors-applet / trunk / PKGBUILD
blob6497dc4c1bc8539b08b829b118fded4990056d94
1 # Maintainer: Alexander Epaneshnikov <alex19ep@archlinux.org>
2 # Contributor: Brad Fanella <cesura@archlinux.org>
3 # Contributor: Martin Wimpress <code@flexion.org>
5 pkgname=mate-sensors-applet
6 pkgver=1.27.0
7 pkgrel=1
8 pkgdesc="A MATE Panel applet to display readings from hardware sensors, including CPU temperature, fan speeds and voltage readings"
9 url="https://mate-desktop.org"
10 arch=('x86_64')
11 license=('GPL')
12 depends=('libatasmart' 'libnotify' 'libxnvctrl' 'lm_sensors' 'mate-panel' 'gettext')
13 makedepends=('docbook-xsl' 'itstool')
14 groups=('mate-extra')
15 source=("https://pub.mate-desktop.org/releases/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz")
16 sha256sums=('93834a99a726ecbff7fde60cd72da8ff0edd367943739fe25305563c532e4eb8')
18 build() {
19         cd "${pkgname}-${pkgver}"
20         ./configure \
21                     --prefix=/usr \
22                     --libexecdir=/usr/lib/${pkgname}
24         #https://bugzilla.gnome.org/show_bug.cgi?id=656231
25         sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
27         make
30 package() {
31         cd "${pkgname}-${pkgver}"
32         make DESTDIR="${pkgdir}" install