archrelease: copy trunk to community-any
[ArchLinux/community.git] / metacity / repos / community-x86_64 / PKGBUILD
blob2fa7683de258c2d93ef6ece3aed89c4445e262ef
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=metacity
5 pkgver=3.46.1
6 pkgrel=1
7 pkgdesc='Window manager of GNOME Flashback'
8 arch=('x86_64')
9 url='https://wiki.gnome.org/Projects/Metacity'
10 license=('GPL')
11 depends=('dconf' 'libcanberra' 'libgtop' 'libsm' 'libxpresent' 'libxres'
12          'gsettings-desktop-schemas' 'gtk3' 'startup-notification' 'zenity')
13 makedepends=('vulkan-headers' 'python')
14 source=("https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz")
15 sha256sums=('00ba49f7612088f2b3baeca79c45eb2a30423c2e4a7bea4015872beae25dd6c5')
17 build() {
18   cd $pkgname-$pkgver
19   ./configure --prefix=/usr --disable-schemas-compile
20   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
21   make
24 package() {
25   cd $pkgname-$pkgver
26   make DESTDIR="$pkgdir" install