1 # Maintainer: Connor Behan <connor.behan@gmail.com>
2 # Contributor: mar77i <mysatyre at gmail dot com>
5 pkgver=0.4.8.r68.g04aee523
7 pkgdesc="SWF output library"
9 url="http://www.libming.net/"
10 license=('GPL' 'LGPL')
11 depends=('freetype2' 'libpng' 'flex' 'giflib')
12 makedepends=('bison' 'pkgconf' 'swig' 'python' 'git')
13 options=('!emptydirs')
14 source=(git+https://github.com/libming/libming.git#commit=04aee52363688426eab74f5d6180c149654a6473 py3.patch ming-0.4.8-swig-4.1.patch)
16 'c33000d71c4e7308c6c4b7a3be05087d6b088b86caa841d0e11585c26cbc1e64'
17 '33cca7f5f5b17805a0ca1b56e4ef1e2be3492169bbb8500a3d872b3ac762758e')
21 git describe --long | sed 's/^ming-//;s/\([^-]*-g\)/r\1/;s/[-_]/./g'
26 export CFLAGS="$CFLAGS -fcommon"
27 git apply ../py3.patch
28 git apply ../ming-0.4.8-swig-4.1.patch
31 PYTHON=/usr/bin/python ./configure --prefix=/usr --enable-python
33 # Strange that this can fail when we let the Makefile do it
34 pushd src/actioncompiler
35 bison -y -p swf4 -b swf4compiler swf4compiler.y
36 bison -y -p swf5 -b swf5compiler swf5compiler.y
43 make DESTDIR="$pkgdir" install