archrelease: copy trunk to community-any
[ArchLinux/community.git] / misfortune / trunk / PKGBUILD
blobcb333d4d3bb7e413a2f397f54a38ca531abe6b93
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=misfortune
4 pkgver=0.1.2.1
5 pkgrel=31
6 pkgdesc="fortune-mod clone"
7 url="https://github.com/ncfavier/misfortune"
8 license=("custom:PublicDomain")
9 arch=('x86_64')
10 depends=('ghc-libs' 'haskell-cereal' 'haskell-knob' 'haskell-monad-loops' 'haskell-random'
11          'haskell-random-fu' 'haskell-regex-base' 'haskell-regex-pcre' 'haskell-utf8-string'
12          'haskell-vector')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
15 sha256sums=('e185ec78aedb5ebe0b4152b8f667907bbdb900a0da95b2c2f8d992ef11c31f6a')
17 build() {
18   cd $pkgname-$pkgver
20   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
24     --ghc-option='-pie'
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $pkgname-$pkgver
35   runhaskell Setup test --show-details=direct
38 package() {
39   cd $pkgname-$pkgver
41   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43   runhaskell Setup copy --destdir="$pkgdir"