1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="fortune-mod clone"
7 url="https://github.com/ncfavier/misfortune"
8 license=("custom:PublicDomain")
10 depends=('ghc-libs' 'haskell-cereal' 'haskell-knob' 'haskell-monad-loops' 'haskell-random'
11 'haskell-random-fu' 'haskell-regex-base' 'haskell-regex-pcre' 'haskell-utf8-string'
14 source=("https://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
15 sha256sums=('e185ec78aedb5ebe0b4152b8f667907bbdb900a0da95b2c2f8d992ef11c31f6a')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 runhaskell Setup test --show-details=direct
41 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43 runhaskell Setup copy --destdir="$pkgdir"