archrelease: copy trunk to community-any
[ArchLinux/community.git] / mixxx / repos / community-x86_64 / PKGBUILD
blob66857975b899e579e501d3592f07455ec84c0df4
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
3 # Contributor: Ali H. Caliskan <ali.h.caliskan AT gmail DOT com>
4 # Contributor: Ryan Coyner <rcoyner@gmail.com>
5 # Contributor: Stefan Husmann <stefan-husmann@t-online.de>
7 pkgname=mixxx
8 pkgver=2.3.5
9 pkgrel=1
10 pkgdesc="Free, open source software for digital DJing"
11 arch=(x86_64)
12 url="https://www.mixxx.org"
13 license=(GPL2)
14 groups=(pro-audio)
15 # TODO: package libshout-idjc
16 depends=(
17   gcc-libs
18   glibc
19   hicolor-icon-theme
20   hidapi
21   lame
22   libmad
23   libmodplug
24   libx11
25   openssl
26   opus
27   opusfile
28   qt5-base
29   qt5-script
30   qt5-svg
31   qt5-x11extras
32   qtkeychain
33   soundtouch
34   speex
35   sqlite
36   taglib
37   upower
38   wavpack
40 makedepends=(
41   chromaprint
42   cmake
43   faad2
44   ffmpeg
45   fftw
46   flac
47   glib2
48   glu
49   gperftools
50   libid3tag
51   libogg
52   libsndfile
53   libusb
54   libvorbis
55   lilv
56   lv2
57   qt5-tools
58   portaudio
59   portmidi
60   protobuf
61   rubberband
62   vamp-plugin-sdk
64 checkdepends=(xorg-server-xvfb)
65 source=(https://github.com/${pkgname}dj/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz)
66 sha512sums=('d81208e8fe91e1843bac7ab512dc248457266b935bf8720694f2bedf96389ba35789d68ea77fcecf0a02682fb75de2752612b2c44a49b8eba52323cab2b82e51')
67 b2sums=('311dc36c5544e34651b4eb824fac2ab70827382295ba1912d53ec9706fc976a89d5417c969cb41e23c22a456953046e472fcbdbe78316949e02e6db7e15704b4')
69 build() {
70   local cmake_options=(
71     -B build
72     -DCMAKE_BUILD_TYPE=Release
73     -DCMAKE_INSTALL_PREFIX=/usr
74     -S $pkgname-$pkgver
75     -Wno-dev
76   )
78   cmake "${cmake_options[@]}"
79   cmake --build build --verbose
82 check() {
83   xvfb-run ctest --test-dir build --output-on-failure
86 package() {
87   depends+=(
88     chromaprint libchromaprint.so
89     flac libFLAC.so
90     ffmpeg libavcodec.so libavformat.so libavutil.so
91     fftw libfftw3.so
92     glib2 libgobject-2.0.so
93     libid3tag libid3tag.so
94     libogg libogg.so
95     libsndfile libsndfile.so
96     libusb libusb-1.0.so
97     libvorbis libvorbis.so libvorbisenc.so libvorbisfile.so
98     lilv liblilv-0.so
99     portaudio libportaudio.so
100     portmidi libportmidi.so
101     protobuf libprotobuf-lite.so
102     rubberband librubberband.so
103   )
105   DESTDIR="$pkgdir" cmake --install build