1 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinux.org>
7 pkgdesc='A system for Python that generates static type annotations by collecting runtime types'
9 url='https://github.com/instagram/MonkeyType'
11 depends=('python-mypy_extensions' 'python-libcst')
12 makedepends=('python-setuptools')
13 checkdepends=('python-pytest-runner' 'python-pytest-cov' 'python-django')
14 source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
16 sha512sums=('1fd0eb9bd83e7f27de5b7e75d06a89d851220b165d8becd7bac75c196361315669142c5f8838e85696e5dceaeaae6b64b71e3e46010546c65fa4f9d9b62f55d2'
17 '81b37bf0ca06a65d10aa5efe7da200564b234247eb63c619a2ad3243ad243f9aebeaf244dfd69c4032341c47febd12e03c8ac5b4fe8dedf21492600c874ac4d3')
22 patch -p1 -i ../py3.9.patch
34 python setup.py pytest
40 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
42 install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
45 # vim:set ts=2 sw=2 et: