archrelease: copy trunk to community-any
[ArchLinux/community.git] / moreutils / repos / community-x86_64 / PKGBUILD
blobe03a436fef83e712388dfca96f55d57c8b18f900
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
4 pkgname=moreutils
5 pkgver=0.67
6 pkgrel=4
7 pkgdesc="A growing collection of the unix tools that nobody thought to write thirty years ago"
8 arch=('x86_64')
9 url="https://joeyh.name/code/moreutils/"
10 license=('GPL')
11 depends=('perl' 'perl-ipc-run' 'perl-timedate' 'perl-time-duration')
12 makedepends=('docbook2x' 'docbook-xml' 'perl-xml-sax' 'git')
13 options=('!emptydirs' 'zipman')
14 replaces=(moreutils-svn)
15 source=("git+https://git.joeyh.name/git/moreutils.git?signed#tag=$pkgver")
16 sha256sums=('SKIP')
17 validpgpkeys=('E85A5F63B31D24C1EBF0D81CC910D9222512E3C7')
19 build() {
20   cd $pkgname
21   make DOCBOOK2XMAN=db2x_docbook2man
24 package() {
25   cd $pkgname
26   make PREFIX="$pkgdir"/usr install
27   chmod 0644 "$pkgdir"/usr/share/man/man1/*
28   mv "$pkgdir"/usr/share/man/man1/ts.1 "$pkgdir"/usr/share/man/man1/ts.1moreutils
29   mv "$pkgdir"/usr/share/man/man1/parallel.1 "$pkgdir"/usr/share/man/man1/parallel-moreutils.1
30   mv "$pkgdir"/usr/bin/parallel "$pkgdir"/usr/bin/parallel-moreutils