archrelease: copy trunk to community-any
[ArchLinux/community.git] / naev / repos / community-x86_64 / PKGBUILD
blobe80e378e1d05f230448d9efff0d0680ba6f8aa6a
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Johan Rehnberg <cleanrock@gmail.com>
4 pkgname=naev
5 pkgver=0.10.5
6 pkgrel=1
7 pkgdesc='2D action/rpg space game'
8 arch=('x86_64')
9 url="https://github.com/naev/naev"
10 license=('GPL3')
11 depends=('glu' 'openal' 'libvorbis' 'sdl2' 'sdl2_image' 'sdl2_mixer' 'libgl' 'libxml2' 'freetype2'
12          'libpng' 'libzip' 'luajit' 'glpk' 'physfs' 'libunibreak' 'suitesparse' 'cblas')
13 makedepends=('freeglut' 'zip' 'meson' 'git' 'python-yaml')
14 source=("https://github.com/naev/naev/releases/download/v$pkgver/naev-$pkgver-source.tar.xz")
15 sha512sums=('21cd876ffe39bf09f39c65d6f744fc8e9ea1fc42f45f78e2ec9950509a37c3382ef91998ae3b0e0ced60c342c80f95e7e0c6a1301f5171d150f3cce3d76d2c00')
17 build() {
18   cd "$pkgname-$pkgver"
20   meson setup -Dprefix=/usr -Dndata_path=/usr/share/naev/ndata -Dblas=cblas build .
21   cd build
22   meson compile
25 package() {
26   cd "$pkgname-$pkgver/build"
28   DESTDIR="$pkgdir" meson install