1 # Maintainer: Christian Rebischke <chris.rebischke@archlinux.org>
2 # Contributor: Conrad Hoffmann <ch@bitfehler.net>
7 pkgdesc="Network configuration abstraction renderer"
9 url="https://github.com/CanonicalLtd/netplan"
24 "https://github.com/CanonicalLtd/${pkgname}/archive/${pkgver}.tar.gz"
26 sha256sums=('09ca8c191f4cc387edb816c48aa77bcaffb712ba54a188fd27ce961eea02aa53')
29 cd "${pkgname}-${pkgver}"
31 # Drop -Werror to avoid the following error:
32 # /usr/include/glib-2.0/glib/glib-autocleanups.h:28:3: error: 'ip_str' may be used uninitialized in this function [-Werror=maybe-uninitialized]
33 sed -e "s/-Werror//g" -i Makefile
40 cd "${pkgname}-${pkgver}"
41 make DESTDIR="${pkgdir}" ROOTPREFIX=/usr SBINDIR=/usr/bin install