archrelease: copy trunk to community-any
[ArchLinux/community.git] / netplan / repos / community-x86_64 / PKGBUILD
blobae109268c37219086bb0632600e930f66f62ae5b
1 # Maintainer: Christian Rebischke <chris.rebischke@archlinux.org>
2 # Contributor:  Conrad Hoffmann <ch@bitfehler.net>
4 pkgname=netplan
5 pkgver=0.106
6 pkgrel=1
7 pkgdesc="Network configuration abstraction renderer"
8 arch=('x86_64')
9 url="https://github.com/CanonicalLtd/netplan"
10 license=('GPL3')
11 depends=(
12   'glib2'
13   'python-yaml'
14   'python-netifaces'
15   'iproute2'
16   'systemd'
18 makedepends=(
19   'python'
20   'pkgconf'
21   'pandoc'
23 source=(
24   "https://github.com/CanonicalLtd/${pkgname}/archive/${pkgver}.tar.gz"
26 sha256sums=('09ca8c191f4cc387edb816c48aa77bcaffb712ba54a188fd27ce961eea02aa53')
28 build() {
29   cd "${pkgname}-${pkgver}"
31   # Drop -Werror to avoid the following error:
32   # /usr/include/glib-2.0/glib/glib-autocleanups.h:28:3: error: 'ip_str' may be used uninitialized in this function [-Werror=maybe-uninitialized]
33   sed -e "s/-Werror//g" -i Makefile
35   env
36   make
39 package() {
40   cd "${pkgname}-${pkgver}"
41   make DESTDIR="${pkgdir}" ROOTPREFIX=/usr SBINDIR=/usr/bin install