archrelease: copy trunk to community-any
[ArchLinux/community.git] / notification-daemon / trunk / PKGBUILD
blob8b04893e7bebe23280cd203baf9a3a044e0974df
1 # Contributor: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Mark Rosenstand <mark@borkware.net>
4 pkgname=notification-daemon
5 pkgver=3.20.0
6 pkgrel=4
7 pkgdesc="Server implementation of the freedesktop.org desktop notification specification"
8 arch=(x86_64)
9 license=(GPL2)
10 url="https://wiki.gnome.org/Projects/NotificationDaemon"
11 depends=(gtk3)
12 makedepends=(intltool)
13 source=("https://download.gnome.org/sources/${pkgname}/${pkgver:0:4}/${pkgname}-${pkgver}.tar.xz")
14 sha256sums=('dd13768f35fd8bba9c4920b0f8269f39270e5a3cfed1a34c3b940a492286ece5')
16 build() {
17     cd "${pkgname}-${pkgver}"
18     ./configure --prefix=/usr --sysconfdir=/etc \
19         --libexecdir=/usr/lib/notification-daemon-1.0 \
20         --localstatedir=/var --disable-static
21     make
24 check() {
25     cd "${pkgname}-${pkgver}"
26     make check
29 package() {
30     cd "${pkgname}-${pkgver}"
31     make DESTDIR="${pkgdir}" install