1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Matthew Bowra-Dean <matthew@ijw.co.nz>
6 pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL"
8 url="https://www.openra.net"
10 install=openra.install
11 depends=('ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme'
12 'gtk-update-icon-cache' 'desktop-file-utils' 'xdg-utils' 'zenity' 'dotnet-sdk-6.0')
13 makedepends=('git' 'unzip')
15 source=("git+https://github.com/OpenRA/OpenRA.git#tag=release-${pkgver}")
21 make version VERSION="release-${pkgver}"
27 make RUNTIME=net6 TARGETPLATFORM=unix-generic
32 mkdir -p "$pkgdir/usr/lib/openra/"
33 cp -r bin/* "$pkgdir/usr/lib/openra/"
34 source ./packaging/functions.sh
35 install_data . "$pkgdir/usr/lib/openra/" cnc d2k ra
36 make prefix=/usr DESTDIR="$pkgdir" install-linux-shortcuts
37 make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata
38 # make prefix=/usr DESTDIR="$pkgdir" install-man