archrelease: copy trunk to community-any
[ArchLinux/community.git] / or1k-elf-binutils / trunk / PKGBUILD
blob741e592b50409a8db65bb86c8bca8fdf397225d1
1 # Maintainer: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
2 # Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
4 _target=or1k-elf
5 pkgname=$_target-binutils
6 pkgver=2.39
7 pkgrel=1
8 pkgdesc='A set of programs to assemble and manipulate binary and object files for the OpenRISC 1000 (bare-metal) target'
9 arch=(x86_64)
10 url='https://www.gnu.org/software/binutils/'
11 license=(GPL)
12 depends=(zlib)
13 source=("https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2"{,.sig})
14 sha512sums=('faa592dd48fc715901ad704ac96dbd34b1792c51e77c7a92a387964b0700703c74be07de45cc4751945c8c0674368c73dc17bbc563d1d2cd235b5ebd8c6e7efb'
15             'SKIP')
16 validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93'  # Tristan Gingold <gingold@adacore.com>
17               '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
19 prepare() {
20   cd binutils-$pkgver
22   sed -i '/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/' libiberty/configure
25 build() {
26   cd binutils-$pkgver
28   ./configure --target=$_target \
29               --with-sysroot=/usr/$_target \
30               --prefix=/usr \
31               --enable-multilib \
32               --enable-interwork \
33               --with-gnu-as \
34               --with-gnu-ld \
35               --disable-nls \
36               --enable-ld=default \
37               --enable-gold \
38               --enable-plugins \
39               --enable-deterministic-archives
41   make
44 check() {
45   cd binutils-$pkgver
47   # unset LDFLAGS as testsuite makes assumptions about which ones are active
48   # do not abort on errors - manually check log files
49   make LDFLAGS="" -k check || true
52 package() {
53   cd binutils-$pkgver
55   make DESTDIR="$pkgdir" install
57   # Remove file conflicting with host binutils and manpages for MS Windows tools
58   rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
59   rm "$pkgdir"/usr/lib/bfd-plugins/libdep.so
61   # Remove info documents that conflict with host version
62   rm -r "$pkgdir"/usr/share/info