archrelease: copy trunk to community-any
[ArchLinux/community.git] / pantheon-files / repos / community-x86_64 / PKGBUILD
blobe302e857070cfaf209ddb09e4d6afd7f069f200e
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=pantheon-files
4 pkgver=6.3.1
5 pkgrel=1
6 pkgdesc='The Pantheon File Browser'
7 arch=(x86_64)
8 url=https://github.com/elementary/files
9 license=(GPL3)
10 groups=(pantheon)
11 depends=(
12   atk
13   cairo
14   gdk-pixbuf2
15   glib2
16   gtk3
17   gvfs
18   libcanberra
19   libcloudproviders
20   libgee
21   libgit2-glib
22   libgranite.so
23   libhandy-1.so
24   libnotify
25   pango
26   plank
27   sqlite
28   zeitgeist
30 makedepends=(
31   flatpak-builder
32   git
33   gnome-common
34   meson
35   vala
37 optdepends=(
38   'contractor: Various context menu entries'
39   'tumbler: Thumbnails generation'
41 _tag=def3de0b02e167e75e5456fc6a762225933ec4fd
42 source=(pantheon-files::git+https://github.com/elementary/files.git#tag=${_tag})
43 sha256sums=(SKIP)
45 pkgver() {
46   cd pantheon-files
48   git describe --tags
51 build() {
52   arch-meson pantheon-files build
53   ninja -C build
56 package() {
57   DESTDIR="${pkgdir}" ninja -C build install
60 # vim: ts=2 sw=2 et: