archrelease: copy trunk to community-any
[ArchLinux/community.git] / pantheon-screenshot / repos / community-x86_64 / PKGBUILD
blob27184fa423c8c56330aa70c2b618eb3cc4f973d3
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=pantheon-screenshot
4 pkgver=6.0.3
5 pkgrel=1
6 pkgdesc='The Pantheon Screenshot Tool'
7 arch=(x86_64)
8 url=https://github.com/elementary/screenshot
9 license=(GPL3)
10 groups=(pantheon)
11 depends=(
12   gdk-pixbuf2
13   glib2
14   gtk3
15   libcanberra
16   libgranite.so
17   libhandy-1.so
19 makedepends=(
20   git
21   intltool
22   meson
23   vala
25 _tag=ece167084327bdbd474f62410f26d51448175d15
26 source=(pantheon-screenshot::git+https://github.com/elementary/screenshot.git#tag=${_tag})
27 b2sums=(SKIP)
29 prepare() {
30   cd pantheon-screenshot
31   git cherry-pick -n 80a5d942e813dd098e1ef0f6629b81d2ccef05ae
34 pkgver() {
35   cd pantheon-screenshot
36   git describe --tags
39 build() {
40   arch-meson pantheon-screenshot build
41   ninja -C build
44 package() {
45   DESTDIR="${pkgdir}" ninja -C build install
48 # vim: ts=2 sw=2 et: