archrelease: copy trunk to community-any
[ArchLinux/community.git] / papilo / trunk / PKGBUILD
blob7cf91c9710613c212ef1376c93d5df1a0461b341
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=papilo
4 pkgver=2.1.2
5 pkgrel=2
6 pkgdesc='Parallel Presolve for Integer and Linear Optimization'
7 arch=(x86_64)
8 url='https://www.scipopt.org/'
9 license=(Apache)
10 depends=(tbb gmp boost-libs)
11 makedepends=(cmake boost)
12 source=(https://github.com/scipopt/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
13 sha256sums=('7e3d829c957767028db50b5c5085601449b00671e7efc2d5eb0701a6903d102f')
15 build() {
16   cmake -B build -S $pkgname-$pkgver \
17     -DCMAKE_INSTALL_PREFIX=/usr \
18     -DCMAKE_BUILD_TYPE=None
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build