archrelease: copy trunk to community-any
[ArchLinux/community.git] / patchelf / repos / community-x86_64 / PKGBUILD
blob76e36bf550d790307107d34cb2b89d81f87cbe11
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: T.J. Townsend <blakkheim@archlinux.org>
3 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
4 # Contributor: xduugu
6 pkgname=patchelf
7 pkgver=0.18.0
8 pkgrel=1
9 pkgdesc='Small utility to modify the dynamic linker and RPATH of ELF executables'
10 url='https://nixos.org/patchelf.html'
11 arch=('x86_64')
12 license=('GPL3')
13 depends=('gcc-libs')
14 source=(https://github.com/NixOS/patchelf/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
15 sha512sums=('6a917d7336b1e8c59f42d4cd1dc725df1378d77657fce13cb31547da1d4805b9df8a834a7b8408fda8aa1dbeb37d0cdca74d8698844ea2f44149f800b802dea6')
16 b2sums=('e6ce4ec3bd89c280bb37230dbeb566b803f09900006e79f7dba74f138f66e17746d331baea4def6a43163024b3d86aa8dbac9b2c6545ac146298a8b84373d03b')
18 prepare() {
19   cd ${pkgname}-${pkgver}
20   autoreconf -fiv
23 build() {
24   cd ${pkgname}-${pkgver}
25   ./configure --prefix=/usr
26   make
29 check() {
30   cd ${pkgname}-${pkgver}
31   make -C tests -j1 check
34 package() {
35   cd ${pkgname}-${pkgver}
36   make DESTDIR="${pkgdir}" install
39 # vim: ts=2 sw=2 et: