archrelease: copy trunk to community-any
[ArchLinux/community.git] / pcmanfm-qt / trunk / PKGBUILD
blobb5790ade7e0f517d64c16b8e141bdc57dc752be4
1 # Maintainer: Jerome Leclanche <jerome@leclan.ch>
2 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
4 pkgname=pcmanfm-qt
5 pkgver=1.3.0
6 pkgrel=1
7 pkgdesc="The LXQt file manager, Qt port of PCManFM"
8 arch=("x86_64")
9 groups=("lxqt")
10 url="https://github.com/lxqt/$pkgname"
11 license=("GPL2")
12 depends=("desktop-file-utils" "libfm-qt" "lxmenu-data" "libfm-qt.so")
13 makedepends=("lxqt-build-tools")
14 optdepends=(
15         "gvfs: for various features like mounting without root, remote filesystems, encrypted filesystems and many others mentioned on https://github.com/lxqt/pcmanfm-qt/wiki"
16         "gvfs-mtp: MTP support (Media Transfer Protocol)"
17         "lxqt-archiver: archive management"
18         "qt5-translations: allow keyboard shortcuts to function in some languages (e.g. German)"
20 source=(
21         "https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
22         "https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz.asc"
24 sha256sums=('7c7ce38cd88e7ee032ccd2f89b5dd7e2b61706e25d00cf8f86e68bab0d760fa4'
25             'SKIP')
26 validpgpkeys=(
27         "169704C6FB490C6892C7F23C37E0AF1FDA48F373"  # Jerome Leclanche <jerome@leclan.ch>
28         "7C733BA5F585AAD669E4D23A42C9C8D3AF5EA5E3"  # Alf Gaida <agaida@siduction.org>
29         "19DFDF3A579BD509DBB572D8BE793007AD22DF7E"  # Pedram Pourang <tsujan2000@gmail.com>
32 build() {
33         cmake -B build -S "$srcdir/$pkgname-$pkgver" \
34                 -DCMAKE_INSTALL_PREFIX=/usr \
35                 -DCMAKE_BUILD_TYPE=None
36         make -C build
39 package() {
40         cd build
41         make DESTDIR="$pkgdir" install