1 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
2 # Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
3 # Contributor: Caleb Cushing <xenoterracide@gmail.com>
5 pkgname=perl-exception-class
8 pkgdesc='A module that allows you to declare real exception classes in Perl'
10 url="https://metacpan.org/release/Exception-Class"
11 license=('PerlArtistic' 'GPL')
12 depends=('perl>=5.8.1' 'perl-class-data-inheritable>=0.02' 'perl-devel-stacktrace>=2.00')
13 options=('!emptydirs')
14 source=(https://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Exception-Class-$pkgver.tar.gz)
15 sha256sums=('5482a77ef027ca1f9f39e1f48c558356e954936fc8fbbdee6c811c512701b249')
18 cd "${srcdir}"/Exception-Class-$pkgver
20 export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
21 unset PERL5LIB PERL_MM_OPT
22 perl Makefile.PL INSTALLDIRS=vendor
27 cd "${srcdir}"/Exception-Class-$pkgver
29 export PERL_MM_USE_DEFAULT=1
35 cd "${srcdir}"/Exception-Class-$pkgver
37 make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
39 find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete