archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-graphviz / repos / community-any / PKGBUILD
blob103ff7c850d1d6d5d2844cbd18f60b9f9f6c5238
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
3 # https://github.com/fukawi2/aur-packages
4 # Contributor: Jason St. John <jstjohn .. purdue . edu>
5 # Contributor: antoniolucas <antoniolucasnobar at gmail dot com>
7 pkgname=perl-graphviz
8 pkgver=2.25
9 pkgrel=1
10 pkgdesc="GraphViz - Interface to AT&T's GraphViz. Deprecated. See GraphViz2"
11 arch=('any')
12 url="https://search.cpan.org/dist/GraphViz"
13 license=('GPL' 'PerlArtistic')
14 options=('!emptydirs')
15 depends=('graphviz' 'perl-file-which' 'perl-ipc-run' 'perl-libwww' 'perl-parse-recdescent'
16          'perl-xml-twig' 'perl-xml-xpath')
17 checkdepends=('perl-test-pod')
18 source=("https://cpan.metacpan.org/authors/id/E/ET/ETJ/GraphViz-$pkgver.tar.gz")
19 sha512sums=('906899f6b45c9d537594e9d99e5c38848a3adeac0677890dd41544e390fcd2d9dcfa46ae1afc5d98bad6011c33b19b340955c36e188fa6953a0dcdda39530730')
21 build() {
22   cd GraphViz-$pkgver
23   perl Makefile.PL INSTALLDIRS=vendor
24   make
27 check() {
28   cd GraphViz-$pkgver
29   make test
32 package() {
33   cd GraphViz-$pkgver
34   make install DESTDIR="$pkgdir"
37 # vim:set ts=2 sw=2 et: