archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-inline / repos / community-any / PKGBUILD
blob72930b67d3ff141ae57b1d79782343150e6f1511
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: François Charette <firmicus ατ gmx δοτ net>
4 pkgname=perl-inline
5 pkgver=0.86
6 pkgrel=1
7 pkgdesc="Write Perl subroutines in other languages"
8 arch=('any')
9 url="https://search.cpan.org/dist/Inline"
10 license=('GPL' 'PerlArtistic')
11 depends=('perl>=5.10.0' 'perl-parse-recdescent>=1.8')
12 options=('!emptydirs')
13 source=("https://cpan.metacpan.org/authors/id/I/IN/INGY/Inline-$pkgver.tar.gz")
14 md5sums=('41cee7671b4bfb06a189221f32697e1c')
16 build() {
17   cd  "$srcdir"/Inline-$pkgver
18   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
19   make
22 package() {
23   cd  "$srcdir"/Inline-$pkgver
24   make install DESTDIR="$pkgdir"
25   find "$pkgdir" -name '.packlist' -delete
26   find "$pkgdir" -name '*.pod' -delete