archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-json-parse / repos / community-x86_64 / PKGBUILD
blobe266e1df5bd3bd34c75abbc8cbf4bd21b1c82b0d
1 # Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
3 pkgname=perl-json-parse
4 pkgver=0.62
5 pkgrel=1
6 pkgdesc="JSON::Parse - Read JSON into a Perl variable"
7 arch=('x86_64')
8 url="https://metacpan.org/release/JSON-Parse"
9 license=('GPL' 'PerlArtistic')
10 depends=('perl>=5.10.0')
11 options=('!emptydirs')
12 source=(https://cpan.metacpan.org/authors/id/B/BK/BKB/JSON-Parse-$pkgver.tar.gz)
13 sha256sums=('6273180f9392497401ddd6d820706f5aa86c1be88891dd6aab4d906b5cff66d9')
15 build() {
16   cd  "$srcdir"/JSON-Parse-$pkgver
17   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
18   make
21 package() {
22   cd  "$srcdir"/JSON-Parse-$pkgver
23   make install DESTDIR="$pkgdir"
24   find "$pkgdir" -name '.packlist' -delete
25   find "$pkgdir" -name '*.pod' -delete