archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-module-pluggable / trunk / PKGBUILD
blobeda43b1ccb18a3e777f9488a5a02d0090ea9450f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Florian Pritz <bluewind@xinu.at>
4 pkgname=perl-module-pluggable
5 pkgver=5.2
6 pkgrel=8
7 pkgdesc='automatically give your module the ability to have plugins'
8 arch=('any')
9 license=('PerlArtistic' 'GPL')
10 options=('!emptydirs')
11 depends=('perl')
12 url='https://metacpan.org/release/Module-Pluggable'
13 source=("https://search.cpan.org/CPAN/authors/id/S/SI/SIMONW/Module-Pluggable-$pkgver.tar.gz")
14 md5sums=('87ce2971662efd0b69a81bb4dc9ea76c')
15 sha512sums=('7df8ee6713c8e0d4df756736c43c2033632cb8887c82ed5b9f38476dbf402b5daa3af83d3b2bd1228afb020ce5855831812f86299b63518e04e0929390b0c5f5')
16 _ddir="Module-Pluggable-$pkgver"
18 build() {
19   cd "$srcdir/$_ddir"
20   perl Makefile.PL INSTALLDIRS=vendor
21   make
24 check() {
25   cd "$srcdir/$_ddir"
26   make test
29 package() {
30   cd "$srcdir/$_ddir"
31   make install DESTDIR="$pkgdir"
34 # vim:set ts=2 sw=2 et: