1 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
2 # Contributor: An Nguyen (stk) <an@linux.com>
3 # Contributor: Francesco Di Battista <teme.[nospace]84 -_AT_- the domain name google offers a mail service at ending in dot com>
5 pkgname=perl-sys-meminfo
8 pkgdesc='Perl extension for return the total amount of physical memory'
10 url='https://metacpan.org/release/Sys-MemInfo'
13 options=('!emptydirs' purge)
14 source=("https://cpan.metacpan.org/authors/id/S/SC/SCRESTO/Sys-MemInfo-${pkgver}.tar.gz")
15 b2sums=('f45ebe017ff40cd612d69b9e804348bed8b78526c18b308a16accf7ffeec1263c2bd8ac6de8ffdf25f9c4e01562a9aa91563f159f0e76268e4bc4f188654a814')
18 cd Sys-MemInfo-${pkgver}
19 unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
20 export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
26 cd Sys-MemInfo-${pkgver}
27 unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
28 export PERL_MM_USE_DEFAULT=1
33 cd Sys-MemInfo-${pkgver}
34 unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
35 make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"