archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-test-mockmodule / repos / community-any / PKGBUILD
bloba8af4fa4f12cd07f2b59d525b87e05f84eb1ad43
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-test-mockmodule
4 pkgver=0.177.0
5 pkgrel=3
6 pkgdesc="Override subroutines in a module for unit testing"
7 arch=('any')
8 license=('PerlArtistic' 'GPL')
9 options=('!emptydirs')
10 depends=('perl-super')
11 makedepends=('perl-module-build')
12 checkdepends=('perl-test-pod' 'perl-test-pod-coverage' 'perl-test-warnings')
13 url='https://search.cpan.org/dist/Test-MockModule'
14 source=("https://search.cpan.org/CPAN/authors/id/G/GF/GFRANKS/Test-MockModule-v$pkgver.tar.gz")
15 sha512sums=('d28523202ba4dbf040e26a3cb0795297c2c4fc65598e7717a51ed8678bce308eec7eb3b5d5d35d71418b21c2c81833679cf1624e0e07c6b1e26e8f7605eb98b3')
17 build() {
18   cd "$srcdir/Test-MockModule-v$pkgver"
19   perl Build.PL installdirs=vendor
20   perl Build
23 check() {
24   cd "$srcdir/Test-MockModule-v$pkgver"
25   perl Build test
28 package() {
29   cd "$srcdir/Test-MockModule-v$pkgver"
30   perl Build install destdir="$pkgdir"
33 # vim:set ts=2 sw=2 et: