archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-test-script / trunk / PKGBUILD
blob4b78179fabfd1bab2802381fd8cdfdaf4d6f9bdc
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-test-script
4 pkgver=1.29
5 pkgrel=3
6 pkgdesc="Basic cross-platform tests for scripts"
7 arch=('any')
8 license=('PerlArtistic')
9 url="https://metacpan.org/release/Test-Script"
10 depends=('perl-capture-tiny' 'perl-probe-perl' 'perl-test2-suite')
11 options=('!emptydirs')
12 source=("https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/Test-Script-$pkgver.tar.gz")
13 sha512sums=('979fade0abc83f8d7d4c1c094fa928e27bd7c9db52140b156689d3b192d9ea84f5824554d6788c9144cf2923a04b1d8a8bdfdcc05a0be5514de92353c9a7d10f')
15 build() {
16   cd Test-Script-$pkgver
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd Test-Script-$pkgver
23   make test
26 package() {
27   cd Test-Script-$pkgver
28   make DESTDIR="$pkgdir" install