archrelease: copy trunk to community-any
[ArchLinux/community.git] / perl-text-charwidth / trunk / PKGBUILD
blobc5a89e70cd897d439cdb2d23a875088e8a3756d5
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Maintainer: Charles Mauch <cmauch@gmail.com>
4 pkgname=perl-text-charwidth
5 pkgver=0.04
6 pkgrel=21
7 pkgdesc="Perl/CPAN Module Text::CharWidth"
8 arch=("x86_64")
9 url="https://search.cpan.org/dist/Text-CharWidth"
10 license=("GPL" "PerlArtistic")
11 options=('!emptydirs')
12 source=("https://www.cpan.org/authors/id/K/KU/KUBOTA/Text-CharWidth-${pkgver}.tar.gz")
13 sha256sums=('abded5f4fdd9338e89fd2f1d8271c44989dae5bf50aece41b6179d8e230704f8')
15 build() {
16   cd Text-CharWidth-${pkgver}
18   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
20   make
23 package() {
24   cd Text-CharWidth-${pkgver}
26   make install DESTDIR="$pkgdir"
28   find "$pkgdir" -name '.packlist' -delete
29   find "$pkgdir" -name '*.pod' -delete