1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Mateusz Herych <heniekk@gmail.com>
9 pkgdesc="Official MusicBrainz tagger"
11 url="https://github.com/metabrainz/picard"
13 depends=(glibc hicolor-icon-theme python-dateutil python-discid
14 python-fasteners python-markdown python-mutagen python-pyjwt python-pyqt5
16 makedepends=(python-build python-installer python-setuptools python-wheel)
17 checkdepends=(python-pytest)
19 'chromaprint: fingerprinting'
20 'qt5-multimedia: media player toolbar'
21 'qt5-translations: full UI translation'
23 source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz{,.asc})
24 sha512sums=('8f2502c517b2cbc776a0990453a459e0ee85af085c534f679d60db2dcaf2c81bc544e1ac6a87f574db58c62552c0602e7e2ec62ea622f357a09a3728173add85'
26 b2sums=('a639ec64a03f0283c8c48ae29cccb851c0baca72de2f706c570b1fff373a23bafb5353229c8aa3193a40f45418cc79ac9f3d50bc237be2cfc2a0fed917c4e94a'
28 # NOTE: GPG signed tags and artifacts are being evaluated: https://tickets.metabrainz.org/browse/PICARD-1934
29 validpgpkeys=('68990DD0B1EDC129B856958167997E14D563DA7C') # MusicBrainz Picard Developers <picard@metabrainz.org>
33 python -m build --wheel --no-isolation
43 python -m installer --destdir="$pkgdir" dist/*.whl
44 install -vDm 644 {AUTHORS.txt,{CONTRIBUTING,NEWS,README}.md} -t "$pkgdir/usr/share/doc/$pkgname/"