archrelease: copy trunk to community-any
[ArchLinux/community.git] / picard / trunk / PKGBUILD
blobfd47d0597bd6cbe1444e176da9fd84c1aee7a6ee
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Mateusz Herych <heniekk@gmail.com>
4 # Contributor: sysrq
6 pkgname=picard
7 pkgver=2.8.5
8 pkgrel=2
9 pkgdesc="Official MusicBrainz tagger"
10 arch=(x86_64)
11 url="https://github.com/metabrainz/picard"
12 license=(GPL2)
13 depends=(glibc hicolor-icon-theme python-dateutil python-discid
14 python-fasteners python-markdown python-mutagen python-pyjwt python-pyqt5
15 python-yaml)
16 makedepends=(python-build python-installer python-setuptools python-wheel)
17 checkdepends=(python-pytest)
18 optdepends=(
19   'chromaprint: fingerprinting'
20   'qt5-multimedia: media player toolbar'
21   'qt5-translations: full UI translation'
23 source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz{,.asc})
24 sha512sums=('8f2502c517b2cbc776a0990453a459e0ee85af085c534f679d60db2dcaf2c81bc544e1ac6a87f574db58c62552c0602e7e2ec62ea622f357a09a3728173add85'
25             'SKIP')
26 b2sums=('a639ec64a03f0283c8c48ae29cccb851c0baca72de2f706c570b1fff373a23bafb5353229c8aa3193a40f45418cc79ac9f3d50bc237be2cfc2a0fed917c4e94a'
27         'SKIP')
28 # NOTE: GPG signed tags and artifacts are being evaluated: https://tickets.metabrainz.org/browse/PICARD-1934
29 validpgpkeys=('68990DD0B1EDC129B856958167997E14D563DA7C') # MusicBrainz Picard Developers <picard@metabrainz.org>
31 build() {
32   cd $pkgname-$pkgver
33   python -m build --wheel --no-isolation
36 check() {
37   cd $pkgname-$pkgver
38   pytest -vv
41 package() {
42   cd $pkgname-$pkgver
43   python -m installer --destdir="$pkgdir" dist/*.whl
44   install -vDm 644 {AUTHORS.txt,{CONTRIBUTING,NEWS,README}.md} -t "$pkgdir/usr/share/doc/$pkgname/"