1 # Maintainer: Justin Kromlinger <hashworks@archlinux.org>
5 pkgdesc='Infinitely transfer between every device over pure HTTP with pipes or browsers'
7 url="https://github.com/nwtgck/piping-server-rust"
12 source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
14 sha256sums=('3735eea652c178ec36118958414b7ce35a246fd64790e2fd04b5d5912f072d30'
15 '9182467638a583b29bed0ae69ed00013b1721ce8753e5ba90a56cbaac07d768c')
18 cd "piping-server-rust-$pkgver"
19 cargo build --release --locked --target-dir=target
23 cd "piping-server-rust-$pkgver"
24 cargo test --release --locked
28 install -Dm644 piping-server.service "$pkgdir/usr/lib/systemd/system/piping-server.service"
30 cd "piping-server-rust-$pkgver"
32 install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
34 install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
35 install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"