archrelease: copy trunk to community-any
[ArchLinux/community.git] / plasma5-applets-active-window-control / repos / community-x86_64 / PKGBUILD
blob9dac9f033efe02ed99d40d317c072b84a283eb44
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
3 # Contributor: Martin Kostolný <clearmartin at zoho dot com>
5 pkgname=plasma5-applets-active-window-control
6 pkgver=1.7.3
7 pkgrel=3
8 pkgdesc="Plasma applet for controlling the currently active window"
9 arch=(x86_64)
10 url="https://github.com/kotelnik/plasma-applet-active-window-control"
11 license=(GPL2)
12 depends=(plasma-workspace qt5-graphicaleffects)
13 makedepends=(extra-cmake-modules)
14 source=($pkgname-$pkgver.tar.gz::"https://github.com/kotelnik/plasma-applet-active-window-control/archive/v$pkgver.tar.gz")
15 sha256sums=('f4662560bffd57155081fb8bb0d82c118204f578c7c681b442e365b6c7d169a9')
17 prepare() {
18   mkdir -p build
21 build() {
22   cd build
23   cmake ../plasma-applet-active-window-control-$pkgver \
24     -DCMAKE_INSTALL_PREFIX=/usr \
25     -DCMAKE_BUILD_TYPE=Release \
26     -DCMAKE_INSTALL_LIBDIR=lib \
27     -DBUILD_TESTING=OFF
30 package() {
31   cd build
32   make DESTDIR="$pkgdir" install