archrelease: copy trunk to community-any
[ArchLinux/community.git] / pop-icon-theme / trunk / PKGBUILD
blobb48b28fc971d7c3037d59d692851253c9b19eb10
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Christopher Reimer <mail@c-reimer.de>
4 pkgname=pop-icon-theme
5 pkgver=3.3.0.r8.ab3e9b1497
6 pkgrel=1
7 pkgdesc='System76 Pop Icon Theme'
8 arch=(any)
9 url=https://github.com/pop-os/icon-theme
10 license=(CCPL)
11 depends=(adwaita-icon-theme)
12 makedepends=(
13   git
14   meson
16 _commit=ab3e9b14970f73dabd0b94025877972312cb82fb
17 source=(pop-icon-theme::git+https://github.com/pop-os/icon-theme.git#commit=${_commit})
18 b2sums=(SKIP)
20 pkgver() {
21   cd pop-icon-theme
22   git describe --tags | sed 's/^v//;s/-/.r/;s/-g/./'
25 build() {
26   arch-meson pop-icon-theme build
27   meson compile -C build
30 package() {
31   DESTDIR="${pkgdir}" meson install -C build
34 # vim: ts=2 sw=2 et: