archrelease: copy trunk to community-any
[ArchLinux/community.git] / psi-nowebkit / trunk / PKGBUILD
blob3eeb37a17d577c7135407554809b94cbd89e7a1f
1 # Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
3 pkgname="psi-nowebkit"
4 pkgver=1.3
5 pkgrel=2
6 pkgdesc="Psi is a powerful Jabber client (Qt, C++) designed for the Jabber power users (without webkit support)"
7 url="https://psi-im.org"
8 license=('GPL2')
9 arch=('x86_64')
10 depends=('qt5-base' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
11          'libidn' 'libxss' 'qt5-svg' 'hunspell' 'qtkeychain')
12 makedepends=('patch' 'cmake')
13 conflicts=('psi')
14 provides=('psi')
15 source=("https://downloads.sourceforge.net/project/psi/Psi/${pkgver}/psi-${pkgver}.tar.xz"
16         "no-qca-qt4.patch::https://aur.archlinux.org/cgit/aur.git/plain/no-qca-qt4.patch?h=psi-plus-git&id=bc3ee431ca26d6294810636a514c50985540bd23"
17         "join.patch")
18 sha256sums=('59debd16e61ab1d4ff88aca9f41b9caaaca8395f1576418fb99214d5e2c6fa8b'
19             'a6ea9a62100b6990b8a6c8590a6d0e9df095b99b6527bb5490a7fd3f6929ac23'
20             '67ff9fe4ebfc7b6a04cd325a677ad0cf6252bd7276bfb7968be80fc6f0ad5dc3')
22 prepare() {
23   cd psi-$pkgver
24   patch -p1 <"$srcdir"/join.patch
25   patch -p1 <"$srcdir"/no-qca-qt4.patch
28 build() {
29   cd psi-$pkgver
30   mkdir -p build
31   cd build
32   cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DENABLE_WEBKIT=OFF ..
33   make
36 package() {
37   cd psi-$pkgver/build
38   make DESTDIR="$pkgdir" install
39   install -dm755 "$pkgdir/usr/include/psi/plugins"
40   install -m644 ../src/plugins/include/*.h "$pkgdir/usr/include/psi/plugins"