archrelease: copy trunk to community-any
[ArchLinux/community.git] / pwgen / trunk / PKGBUILD
blob33e19794ddc7f5d91e140fea82f0821c35be3766
1 # Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
2 # Contributor: damir <damir@archlinux.org>
3 # Contributor: Tobias Powalowski <t.powa@gmx.de>
5 pkgname=pwgen
6 pkgver=2.08
7 pkgrel=2
8 pkgdesc='Password generator for creating easily memorable passwords'
9 arch=('x86_64')
10 url='https://sourceforge.net/projects/pwgen/'
11 license=('GPL')
12 depends=('glibc')
13 validpgpkeys=('3AB057B7E78D945C8C5591FBD36F769BC11804F0')
14 source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
15 sha256sums=('dab03dd30ad5a58e578c5581241a6e87e184a18eb2c3b2e0fffa8a9cf105c97b'
16             'SKIP')
18 prepare() {
19   cd "$pkgname-$pkgver"
21   autoconf
24 build() {
25   cd "$pkgname-$pkgver"
27   ./configure --prefix=/usr --mandir=/usr/share/man
28   make
31 package() {
32   make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
35 # getver: sf.net/p/pwgen/code/ci/master/tree/Makefile.in?format=raw
36 # vim: ts=2 sw=2 et: