1 # Maintainer: kpcyrd <kpcyrd[at]archlinux[dot]org>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: KokaKiwi <kokakiwi+aur@kokakiwi.net>
6 pkgname=python-${_pyname}
9 pkgdesc="A Python implementation of ADB with shell and FileSync functionality."
11 url="https://github.com/JeffLIrion/adb_shell"
13 depends=('python' 'python-cryptography' 'python-pyasn1' 'python-rsa')
14 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
15 optdepends=('python-aiofiles: async API'
16 'python-libusb1: To connect to a device via USB')
17 conflicts=('python-adb_shell')
18 source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/JeffLIrion/adb_shell/archive/refs/tags/v${pkgver}.tar.gz")
19 b2sums=('c7e49766dfa70db60eb300f747957397c252325670b40d0d7355ae321558ac671bdcc5beb6b16876b79f7d803b933c1d26d41a5799b4fe058fbdb9739442389a')
22 cd "${_pyname/-/_}-${pkgver}"
27 cd "${_pyname/-/_}-${pkgver}"
28 python -m installer -d "$pkgdir" dist/*.whl
29 install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"