1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
4 pkgname=python-${_pyname}
7 pkgdesc='Classes with architecture-specific information useful to other projects'
8 url='https://github.com/angr/archinfo'
10 license=('custom:BSD2')
12 makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
19 source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
20 sha512sums=('d98f7bfcaca493b82f6e11c8a84324b60d3b69154f29cbe2d9882712e13592b0971f600c3d461d764c67cf7afde12995110ca349f75030c013ef379e21f9c55e')
21 b2sums=('faa6344f873efb0b376d07214502d0ffc767315a3b605c45184580622b199ce385c0c44141435f103cf8c39084c11d767a40520b986c3c3947db4f52a3e270bc')
24 cd "${_pyname}-${pkgver}"
25 python -m build --wheel --no-isolation
29 cd "${_pyname}-${pkgver}"
30 python -m installer --destdir="$pkgdir" dist/*.whl
31 install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
32 install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"