archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-aresponses / repos / community-any / PKGBUILD
blob108eb2937a406d1af78fe37b9d7ea57f69661695
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-aresponses
4 pkgver=2.1.6
5 pkgrel=2
6 pkgdesc="Asyncio http mocking. Similar to the responses library used for 'requests'"
7 url="https://github.com/circleup/aresponses"
8 license=('MIT')
9 arch=('any')
10 depends=('python-aiohttp' 'python-pytest-asyncio')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-cov')
13 source=("https://github.com/circleup/aresponses/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('9fffe4a0a5f1dccbe8743c9d6df765accd36eefff964319d9d31b8f5eb93647b0ad142ec870e47a8d59d66a94c167a5f53851029cf962dba38e7813ad9d23a48')
16 build() {
17   cd aresponses-$pkgver
18   python setup.py build
21 check() {
22   cd aresponses-$pkgver
23   python -m pytest
26 package() {
27   cd aresponses-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/