archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-argh / repos / community-any / PKGBUILD
blob225c3b40e006c49a060fb156aa3440f1d3d66138
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Francois Boulogne <fboulogne at april dot org>
4 pkgname=python-argh
5 pkgver=0.28.1
6 _commit=1872281cce5d554a0ce3c340e24261a7741712cc
7 pkgrel=2
8 pkgdesc="An unobtrusive argparse wrapper with natural syntax"
9 arch=(any)
10 url="https://pypi.python.org/pypi/argh"
11 license=('LGPL3')
12 depends=('python')
13 optdepends=('python-argcomplete: for completion')
14 makedepends=('git' 'python-build' 'python-installer' 'python-flit-core')
15 checkdepends=('python-pytest' 'python-argcomplete' 'python-iocapture')
16 source=("git+https://github.com/neithere/argh.git#commit=$_commit")
17 sha256sums=('SKIP')
19 build() {
20   cd argh
21   python -m build -nw
24 check() {
25   cd argh
26   PYTHONPATH=src pytest
29 package() {
30   cd argh
31   python -m installer -d "$pkgdir" dist/*.whl