1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-aspectlib
6 pkgdesc="Development library for quickly writing configurable applications and daemons"
9 url="https://github.com/ionelmc/python-aspectlib"
10 depends=('python-fields')
11 makedepends=('python-setuptools')
12 checkdepends=('python-tornado' 'python-process-tests'
13 'python-profilestats' 'python-pytest-runner') # 'mysql-python')
14 source=("$pkgname-$pkgver.tar.gz::https://github.com/ionelmc/python-aspectlib/archive/v$pkgver.tar.gz"
16 sha512sums=('33642f828989d07c6af78bdf9adc9f2abbc419df89b878cfe7bd9c8df226a59401176b56b1f2b3ba48661ea5a145520de0bc7a0980226b742b0a79f31ab7dd7f'
17 '74b4261afd1fe20749f94dab067514eab12c484453607b820a96e1e8308fddbac4ac49ce24334c79c9fea6729877457ae60cb5004709106186c51d9af66087af')
20 cd python-aspectlib-$pkgver
21 # https://github.com/ionelmc/python-aspectlib/pull/22
22 patch -Np1 -i ../python310.patch
26 cd python-aspectlib-$pkgver
31 cd python-aspectlib-$pkgver
32 # https://github.com/ionelmc/python-aspectlib/issues/15
33 python setup.py pytest --addopts '--deselect tests/test_integrations_py3.py::test_decorate_tornado_coroutine'
37 cd python-aspectlib-$pkgver
38 python setup.py install --root="$pkgdir" --optimize=1
39 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE