archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-async-timeout / repos / community-any / PKGBUILD
blob906fcb6a939c09265729aaf33754c91c09fc6cb4
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Stunts <f.pinamartins[at]gmail.com>
3 # Contributor: Phil Schaf <flying-sheep[at]web.de>
4 # Contributor: Carl George < arch at cgtx dot us >
6 _pkgname=async-timeout
7 pkgname=python-async-timeout
8 pkgver=4.0.2
9 pkgrel=3
10 pkgdesc='Asyncio-compatible timeout class'
11 url='https://github.com/aio-libs/async-timeout'
12 arch=('any')
13 license=('Apache')
14 depends=('python' 'python-typing_extensions')
15 makedepends=('python-setuptools')
16 checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-asyncio' 'python-pytest-aiohttp')
17 source=(https://github.com/aio-libs/async-timeout/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
18 sha256sums=('1eb41fc35a0a24461b00f3479553972c99300e194eb212ff8b816c90c084d1d4')
19 sha512sums=('d7c6c3bdeb5cfc8bbe8ceae290a386c05873e08c8ad9e383d96c5c8f4da2ab165fa0ba70edc7f5b861f80a44db3c51d32dbafd64af5c01d374fbe0cb5f608196')
21 build() {
22   cd ${_pkgname}-${pkgver}
23   python setup.py build
26 check() {
27   cd ${_pkgname}-${pkgver}
28   PYTHONPATH=. py.test tests
32 package() {
33   cd ${_pkgname}-${pkgver}
34   python setup.py install --root="${pkgdir}" -O1 --skip-build
37 # vim: ts=2 sw=2 et: