2 # Contributor: Donald Webster <fryfrog@gmail.com>
4 pkgname=python-attrdict
5 _name=${pkgname#python-}
8 pkgdesc='A library that provides mapping objects that allow their elements to be accessed both as keys and as attributes'
10 url='https://pypi.org/project/attrdict/'
13 makedepends=(python-build python-installer python-setuptools python-wheel)
14 source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
15 sha256sums=('35c90698b55c683946091177177a9e9c0713a0860f0e049febd72649ccd77b70')
20 find . -type f -iname '*.py' -exec sed -i 's/collections/collections.abc/g' {} +
25 python -m build --wheel --no-isolation
30 python -m installer --destdir="$pkgdir" dist/*.whl
31 install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname