4 pkgname=python-$_pyname
7 pkgdesc='Wrapper for the blosc2 compressor'
9 url='https://github.com/Blosc/python-blosc2'
11 depends=(blosc2 python-py-cpuinfo python-msgpack python-ndindex python-rich)
12 makedepends=(python-build python-installer python-setuptools python-scikit-build cmake cython ninja python-numpy)
13 checkdepends=(python-pytest)
14 source=(https://github.com/Blosc/python-blosc2/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('8808e6d04ba97cdc298c72dacacc16bb675d94cdaac6fa73c5bbd81842740069')
19 sed -e 's|, \"cmake\", \"ninja\", \"oldest-supported-numpy\"||' -i pyproject.toml
24 export CMAKE_ARGS="-DUSE_SYSTEM_BLOSC2=ON"
25 python -m build --wheel --no-isolation
30 python -m venv --system-site-packages test-env
31 test-env/bin/python -m installer dist/*.whl
32 test-env/bin/python -m pytest -v
37 python -m installer --destdir="$pkgdir" dist/*.whl
38 install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname