archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-bracex / trunk / PKGBUILD
bloba05cb55c2dda2698614d0dcdc04a834f01b1b8f3
1 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
3 pkgname=python-bracex
4 pkgver=2.3
5 pkgrel=2
6 pkgdesc='Bash style brace expansion for Python'
7 arch=('any')
8 url='https://github.com/facelessuser/bracex'
9 license=('MIT')
10 makedepends=('python-build' 'python-hatchling' 'python-installer' 'python-wheel')
11 source=("https://github.com/facelessuser/bracex/archive/${pkgver}/bracex-${pkgver}.tar.gz")
12 b2sums=('c48b668c35d40337fe9096c8fbc67565ea74abf330a278e1fe070055fcf8835a60dc23fba40c0f1c0677d506c7d8f8ca5168f809b13ab0442868bc962faaf1d5')
14 build() {
15   cd bracex-${pkgver}
16   python -m build --wheel --skip-dependency-check --no-isolation
19 package() {
20   cd bracex-${pkgver}
21   python -m installer --destdir="${pkgdir}" dist/*.whl
22   install -Dm644 LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE