archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-cchardet / trunk / PKGBUILD
blob5d7ee886f942cdfbe6ea72f1ff894f301589b39b
1 # Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
3 pkgname=python-cchardet
4 pkgver=2.1.7
5 pkgrel=5
6 pkgdesc="Universal encoding detector faster than chardet."
7 url="https://pypi.org/project/cchardet/"
8 depends=('python')
9 makedepends=('cython' 'python-setuptools')
10 license=('GPL' 'LGPL' 'MPL')
11 arch=('x86_64')
12 source=(https://files.pythonhosted.org/packages/source/c/cchardet/cchardet-$pkgver.tar.gz)
13 sha256sums=('c428b6336545053c2589f6caf24ea32276c6664cb86db817e03a94c60afa0eaf')
15 build() {
16     cd "$srcdir/cchardet-$pkgver"
17     python setup.py build
20 package_python-cchardet() {
21     cd "$srcdir/cchardet-$pkgver"
22     python setup.py install --skip-build -O1 --root="$pkgdir"