1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-configargparse
6 pkgdesc='A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables'
8 url='https://github.com/bw2/ConfigArgParse'
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest' 'python-tests' 'python-yaml')
13 optdepends=('python-yaml: for YAML support')
14 source=("https://github.com/bw2/ConfigArgParse/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
15 sha512sums=('bdc0340bd92cfd5319743a4860af80fc2352f38b156031856c2b39b8c8ad59461281009030c4451dd464334a829b8143c765979cfc9b8ccbe9fbdcb0e08ac7b4')
18 cd ConfigArgParse-$pkgver
23 cd ConfigArgParse-$pkgver
28 cd ConfigArgParse-$pkgver
29 python setup.py install --root="$pkgdir" --optimize=1
30 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/