1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-cython-lint
6 pkgdesc='A tool to lint Cython files'
8 url='https://github.com/MarcoGorelli/cython-lint'
23 checkdepends=('python-pytest')
24 _commit='ee720d6332a996d755b8919de55fc75d408be768'
25 source=("$pkgname::git+$url#commit=$_commit")
31 git describe --tags | sed 's/^v//'
37 python -m build --wheel --no-isolation
43 PYTHONPATH="$(pwd)" pytest -v
49 python -m installer --destdir="$pkgdir" dist/*.whl
52 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE