archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-database-cubic-hecke / trunk / PKGBUILD
bloba7ab38a409f842a87a9d499303271ef90e0640ce
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 _pipname=database_cubic_hecke
4 pkgname=python-${_pipname//_/-}
5 pkgver=2022.4.4
6 pkgrel=2
7 pkgdesc='Representations of the cubic Hecke algebra on 4 strands as Python dictionaries'
8 arch=(any)
9 url='https://github.com/soehms/database_cubic_hecke'
10 license=(GPL)
11 depends=(python)
12 makedepends=(python-build python-installer python-setuptools-scm python-wheel)
13 source=(https://pypi.io/packages/source/d/$_pipname/$_pipname-$pkgver.tar.gz)
14 sha256sums=('553654a4ce987a277fe956a9a450d738bd1f58b96c45499075e28f2bca927ae9')
16 build() {
17   cd $_pipname-$pkgver
18   python -m build --wheel --no-isolation
21 package() {
22   cd $_pipname-$pkgver
23   python -m installer --destdir="$pkgdir" dist/*.whl