1 # Maintainer: Andrew Crerar <crerar@archlinux.org>
2 # Contributor: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Hideaki Takahashi <mymelo+aur@gmail.com>
4 # Contributor: Vincent Demeester <vincent@sbr.pm>
6 pkgname=python-docker-pycreds
9 pkgdesc="Python bindings for the docker credentials store API"
12 url="https://github.com/shin-/dockerpy-creds"
13 depends=('python-six')
14 makedepends=('python-setuptools')
15 checkdepends=('python-pytest-runner' 'flake8' 'python-pytest-cov')
16 source=("$pkgname-$pkgver.tar.gz::https://github.com/shin-/dockerpy-creds/archive/$pkgver.tar.gz")
17 sha512sums=('5c7c75a654693c6439592201bba6082af2962fab8d25af980ebb3ad2aede42973c31dbc2693eea1212f911980725bab257f973c7498b3555f68fae1630cfc62c')
20 cd "$srcdir"/dockerpy-creds-$pkgver
25 cd "$srcdir"/dockerpy-creds-$pkgver
26 python setup.py pytest
30 cd dockerpy-creds-$pkgver
31 python setup.py install --root="$pkgdir" --optimize=1