1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
3 # Contributor: Carl George < arch at cgtx dot us >
6 pkgdesc="A pure-Python git object database"
8 _commit=bb7d69697b9d24885217b37b94cc0bf4da676fd4 # refs/tags/4.0.10^{}
12 url="https://github.com/gitpython-developers/gitdb"
15 depends=(git python-smmap)
16 makedepends=(git python-build python-installer python-setuptools python-wheel)
17 checkdepends=(python-nose python-pytest)
18 source=(git+$url#tag=$_commit?signed)
20 validpgpkeys=('27C50E7F590947D7273A741E85194C08421980C9') # Sebastian Thiel (In Rust I trust!) <byronimo@gmail.com>
24 python -m build --wheel --no-isolation
27 # some tests need to be disabled, because of coupling with the project
28 # repository: https://github.com/gitpython-developers/gitdb/issues/51
31 local TEST_TMPDIR=$(mktemp -d)
35 git config user.name "Test User"
36 git config user.email "test@user.org"
37 for commit in {1..50}; do
40 git commit -m "file$commit"
43 export GITDB_TEST_GIT_REPO_BASE="$TEST_TMPDIR/.git"
44 pytest -vv -k "not test_pack_writing"
49 python -m installer --destdir="$pkgdir" dist/*.whl
50 install -vDm 644 {AUTHORS,README.rst} -t "$pkgdir/usr/share/doc/$pkgname/"
51 install -vDm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"