1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Guillaume Horel <guillaume.horel@gmail.com>
4 pkgname=python-google-auth-oauthlib
5 _pkgname='google-auth-oauthlib'
8 pkgdesc="oauthlib integration for Google auth."
9 url="http://google-auth-oauthlib.readthedocs.io/en/latest/"
10 checkdepends=('python-click' 'python-pytest')
11 makedepends=('python-setuptools')
12 depends=('python' 'python-google-auth' 'python-requests-oauthlib')
13 optdepends=('python-click')
16 source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
17 sha256sums=('e375064964820b47221a7e1b7ee1fd77051b6323c3f9e3e19785f78ab67ecfc5')
20 # cd "${srcdir}/${_pkgname}-${pkgver}"
25 cd "${srcdir}/${_pkgname}-${pkgver}"
26 python setup.py install --root="${pkgdir}" --optimize=1
27 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE