archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-hachoir / trunk / PKGBUILD
blob3cb332ef1a82ef499f8c113b9b6a693c184c93ca
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Luis Martinez <luis dot martinez at tuta dot io>
3 # Contributor: Michal Wojdyla < micwoj9292 at gmail dot com >
4 # Contributor: arno <apithon.AT.free.DOT.fr>
5 # Contributor: Pierre Bourdon <delroth@gmail.com>
6 # Contributor: ianux <ianux AT free DOT fr>
8 pkgname=python-hachoir
9 pkgver=3.2.0
10 pkgrel=2
11 pkgdesc='A Python library to view and edit a binary stream field by field'
12 arch=('any')
13 url='https://hachoir.readthedocs.io/'
14 license=('GPL')
15 depends=(
16   'python'
17   'python-urwid'
18   'python-wxpython'
19   'python-darkdetect'
21 makedepends=(
22   'git'
23   'python-build'
24   'python-installer'
25   'python-wheel'
26   'python-setuptools'
28 _commit='90c624d976eb64064f370ee5a3c040535182ef49'
29 source=("$pkgname::git+https://github.com/vstinner/hachoir.git#commit=$_commit")
30 b2sums=('SKIP')
32 pkgver() {
33   cd "$pkgname"
35   git describe --tags
38 build() {
39   cd "$pkgname"
41   python -m build --wheel --no-isolation
44 check() {
45   cd "$pkgname"
47   python runtests.py
50 package() {
51   cd "$pkgname"
53   python -m installer --destdir="$pkgdir" dist/*.whl